Haber

Android 7.1.1 Öncesi Telefonlar Eylül 2021 İtibarıyla Güvenli Sitelere Erişim Sağlayamayacak

Android 7.1.1 Öncesi Telefonlar Eylül 2021 İtibarıyla Güvenli Sitelere Erişim Sağlayamayacak

Yeni bir sertifika otoritesi çıkış yaptığı süre ilginç bir ikilemle karşılaşıyor. Sertifikanın insanlara yardımsever olabilmesi için kök sertifikasının dağıtılmış işletim sistemleri ve tarayıcılar tarafından güvenilmesi gerekiyor. Oysa işletim sistemlerinin ve tarayıcıların yeni kök sertifikaya güvenmesi yılları bile alabiliyor.

İşte sertifika otoritesi Let’s Encrypt, bu sorunun üstesinden öbür bir çözümle gelmişti. Otorite, yeni sertifikanın tez cihazlara yayılması için güvenilir bir diğer sertifikadan çapraz imza istemişti. Şirketin çapraz imzayı sağladığı öteki otorite IdenTrust’tı. Fakat şirketin bağımlı olduğu DST Root X3 kök sertifikası bundan böyle zamanını yitiriyor.

Let’s Encrypt’in kendi sertifikasına geçmesi Android kullanıcılarını üzecek:

android 7.1

Bugün Let’s Encrypt tarafından paylaşılan yazıda otorite, IdenTrust’ın DST Root X3 kök sertifikasının 1 Eylül 2021 tarihi itibarıyla süresini dolduracağını açıkladı. Yani kök sertifika bu tarih itibarıyla cihazlar kadar desteklenmeyecek. Oysa Let’s Encrypt, kendi sertifikalarını kullanacaklarını da açıklamada belirtti.

Let’s Encrypt kendi kök sertifikaları olan ISRG Root X1‘ı kullanacaklarını belirtse de besbelli büyük bir sorun bulunuyor. ISRG Root X1 kök sertifikası, 2016 yılından bu yana güncellenmeyen yazılımlar kadar desteklenmiyor. Bu yazılım listesi aralarında Android 7.1.1 Nougat’dan önceki Android sürümleri de bulunuyor.

Güvenli sitelere erişim sağlanamayacak:

android

Android 7.1.1’den önceki Android sürümleri ISRG Root X1’ı güvenilir saymadığından nedeniyle bu sürümlere sahip Android cihazlar öyle fazla güvenilir internet sitesine erişim sağlayamayacaklar. Kullanıcılar için erişim sağlamanın bir yolu fakat Let’s Encrypt ortağı Mozilla’nın Firefox tarayıcısı olacak.

Let’s Encrypt’in açıklamasına göre Google Play’de Android kullanıcılarının %33,8’lik kısmı Android 7.1 ve daha eski sürümleri kullanıyor. Eğer sizler de bu sürümlere sahip bir akıllı telefon kullanıyorsanız sitelere erişim sağlamak için birazcık daha pozitif uğraşmanız veya yeni bir akıllı telefon almanız gerekecek.

Comments
To Top